summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2017-08-17 09:33:34 -0700
committerDylan Baker <dylan@pnwbakers.com>2017-08-17 09:36:25 -0700
commit5cbc78f9aa19383f318e5853fed7a5cee91174a9 (patch)
treea918f68913281122affd3b4ff16264afea9c6704 /setup.py
parente6927d5f808fc0107dc72e5b30daf0473008a2e1 (diff)
setup.py: Add a python_requires field
This field instructs tools like pip and setup tools about which versions of python you support. In alot's case that is currently 2.7.x Fixes #1118
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index fc99e46c..262b0bf0 100755
--- a/setup.py
+++ b/setup.py
@@ -53,4 +53,5 @@ setup(
],
provides=['alot'],
test_suite="tests",
+ python_requires=">=2.7,<3.0",
)