summaryrefslogtreecommitdiff
path: root/quantum
Commit message (Collapse)AuthorAge
* Reduce duplication for ARM/AVR ws2812 RGB Matrix driver (#7180)Joel Challis2019-10-29
| | | | | | * Reduce duplication for ARM/AVR ws2812 rgb_matrix driver * Reduce duplication for ARM/AVR ws2812 rgb_matrix driver - Fix setled_all use of r,g,b
* Fix formatting for sendstring LUTs (#7176)fauxpark2019-10-28
|
* Fix Tap Dance name for consistency and to match docs (#7136)Drashna Jaelre2019-10-24
|
* Fix held key getting stuck when NKRO is toggled (#6570)just-another-jxliu2019-10-22
| | | | | | | | * Fix held key getting stuck when NKRO is toggled * Updated file to latest qmk version and added fix to cases MAGIC_UNHOST_NKRO & MAGIC_HOST_NKRO as well. * Revert merged quantum.c
* Remove build option firmware size impacts (#6947)Amber Holly2019-10-18
| | | | | | | | | | | | | | | | | | | | | | * Update rules.mk template to remove build option size impacts * Add rules.mk cleaning script * Update all rules.mk files to remove build option firmware size impact messages * Remove references to feature filesize in documentation * Revert "Update all rules.mk files to remove build option firmware size impact messages" This reverts commit 7cfe70976bcc223bf47c960b2e6af8596df80a32. * Fix regex in cleanup script and exclude keymaps/ directories * Update quantum/template/avr/rules.mk Fixed missing tabs/spaces. Co-Authored-By: fauxpark <fauxpark@gmail.com>
* SPLIT - Remove NO_USB_STARTUP_CHECK requirement for usb detection (#7053)Joel Challis2019-10-17
| | | | | | | | | | * Avoid NO_USB_STARTUP_CHECK - Disable USB as checks seem to enable it somehow * Update quantum/split_common/split_util.c Co-Authored-By: fauxpark <fauxpark@gmail.com> * Also remove NO_USB_STARTUP_CHECK from vitamins_included/rev1
* Move tmk_core/common/backlight to quantum/backlight (#6710)Joel Challis2019-10-17
| | | | | | | | | | | | * Move tmk_core/common/backlight to quantum/backlight * Add guards to backlight inclusion * Add guards to backlight inclusion * Update backlight guards on clueboard/60 * Use full paths to avoid vpath issues
* Fix bug in `do_code16()` (#6935)fauxpark2019-10-16
| | | | | | * Fix bug in `do_code16()` * Remove qk_ mods functions
* Fix small hiccup in snake animation (#6858)theVDude2019-10-15
|
* Added uart config for using rn42 with at90usb1286 (#6582)Deckweiss2019-10-16
| | | | | | | | | | | | | | | | * Added uart config for using rn42 with at90usb1286 * Updated quantum/config_common.h Co-Authored-By: fauxpark <fauxpark@gmail.com> * Update quantum/config_common.h Co-Authored-By: fauxpark <fauxpark@gmail.com> * Update quantum/config_common.h Co-Authored-By: fauxpark <fauxpark@gmail.com>
* Fix broken link to ps2avrgb flashing instructions (#7011)MechMerlin2019-10-11
|
* ARM split - detect USB to select master/slave (#6424)Joel Challis2019-10-11
| | | | | | | | | | | | * Initial split refactor to allow usb master detection * Add split USB detect docs * Add SPLIT_USB_DETECT demo mode limitation * fix rebase issues * clang-format
* Fix CONVERT_TO_PROTON_C_RXLED pins (#7007)Joel Challis2019-10-11
|
* Prevent clang-format messing up placeholder tokens within keyboard templates ↵fauxpark2019-10-10
| | | | | | | | | | (#6790) * Use .template file extension for keyboard template files * Filter out .template files completely before passing to clang-format * Undo file extension stuff; just ignore quantum/template dir
* ARM - Initial backlight support (#6487)Joel Challis2019-10-05
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Move AVR backlight to own file, add borrowed ARM implementation * Tiny fix for backlight custom logic * Remove duplicate board from rebase * Fix f303 onekey example * clang-format * clang-format * Remove backlight keymap debug * Initial pass of ARM backlight docs * Initial pass of ARM backlight docs - resolve todos * fix rules validation logic * Add f072 warning * Add f072 warning * tidy up breathing in backlight keymap * tidy up breathing in backlight keymap * add missing break to backlight keymap
* Fix quantum keymapextra italian (#6779)Silvio Gulizia2019-10-03
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * remove IT_PIPE duplicate and add IT_GRAD IT_PIPE was declared 2 times, ones as ° and once as |. I changed the first declaration and called it IT_GRAD. I even fixed the definition because the ° in Italian is obtained with LSFT(IT_AACC) * rename IT_GRAD to IT_DEGR * add missing plus_and_minus * fix missing IT_ACUT definition * change KC_LALT(KC_LSFT to LALT(LSFT * Fix alignment * remove leftover * fix issue generated with chars while pushing * fix typo * fix LCBR and RCBR * fix euro symbol * fix RBRC * change IT_LESS form KC_NUBS to KC_GRAVE * add IT_TILDE and change IT_GRAV to IT_GRAVE * add missing legends for accented vowels * format for readability * revert to commit befor I edit it * initial commit * edited to be easier to compare to _ansi.h * remove keymap_italian_osx_iso.h and rename with edits keymap_italian_osx_ansi.h to keymap_italian_osx.h I found out there were no difference at all * fix missing #endif * rename quantum/keymap_extras/keymap_italian_osx.h to quantum/keymap_extras/keymap_italian_ansi.h Now this file is a clone of the keymap_italian.h that appears to be working only for ISO keyboards. It also contains a few improvements for IT_PIPE (defined two times) and IT_ACUT (missing definition). Additionally it redefines LCBR and RCBR to LSFT(IT_LBRC) and LSFT(IT_RBRC) * rename file * redefines IT_BKSL and IT_PIPE based on KC_BKSL * add new osx_iso and osx_ansi version for italian.h and align BKSL to BSLS, fix double definition of PIPE
* ARM split - Add bootmagic/magic keycodes for setting handedness (#6545)Joel Challis2019-09-24
| | | | | | | | | | * Add docs on bootmagic/magic keycodes for setting handedness * Clang format fixes * Maintain backwards compatibility * Maintain backwards compatibility
* Generalize Tap Dance Layer functions (#6629)Drashna Jaelre2019-09-21
| | | | | | | | | | | | | | * made tapdance dual_role general * updated original dual_role functionality * added toggling layer example * Fix dual role and add alias * Update docs about new layer tap dances * Fix up based on feedback
* Add support for 328P hardware backlight on B1/B2 (#6776)fauxpark2019-09-20
|
* Cleanup rules.mk for 32A and 328P keyboards (#6767)fauxpark2019-09-20
|
* DRV2605L Continuous Haptic Feedback Support (#6461)MechMerlin2019-09-19
| | | | | | | | | | | | | | | | | | | | | | | | * provide means to turn on RTP mode and set the amplitude * new keycode HPT_CONT to turn RTP off/on * introduce new keycodes HPT_CONI, and HPT_COND for Haptic Continuous Increase and Decrease * support for continuous mode amplitude increase and decrease * code cleanup * update docs to reference new keycodes and functionality * don't touch the keymaps * add function prototypes * add proper guards * cleanup guards * remove extra reserved
* Smoother Linear Light Table (#6764)XScorpion22019-09-18
|
* Updated split encoders so indexes are based on left hand encoders first (#6382)XScorpion22019-09-18
| | | | | | | | | * Updated encoder.c so that split encoders are indexed based on left hand encoders first. This ensures when swapping master sides that code logic based on encoder index doesn't change. PR Review fixes * Removed extra define
* Add 328P to mcu_selection.mk (#6682)fauxpark2019-09-07
|
* Add 16U2, 16U4 and USB646 to mcu_selection.mk (#6566)fauxpark2019-09-05
|
* Add Dip Switch as a core feature (#6140)Drashna Jaelre2019-09-03
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Add Dip Switches as a core feature * Add documentation for Dip Switch feature * Update Preonic Rev3 to use new feature and remove custom matrix * Apply suggestions from code review Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Remove custom matrix line completely Rather than just disabling it Co-Authored-By: fauxpark <fauxpark@gmail.com> * DIP changes Co-Authored-By: fauxpark <fauxpark@gmail.com> * Use better check for DIP Switch configuration * Add to show features * Add bitmask callback for dip switch * Fix OLKB Boards dip switch config * Update docs to include bitmask example * Fix comments/documentation Co-Authored-By: fauxpark <fauxpark@gmail.com> * Fix issues with docs and use example from @tuzonghua * Fix wording Co-Authored-By: fauxpark <fauxpark@gmail.com> * Fix example to use proper formatting Bad, BAAAAAAD drashna!!! * Handle dip switch initialization better
* clang-format changesskullY2019-08-30
|
* Hotfix: Reinstate the KC_DELT aliasskullY2019-08-30
|
* Remove KC_DELT alias in favor of KC_DEL (#6327)Konstantin Đorđević2019-08-30
| | | | | | * Remove KC_DELT alias in favor of KC_DEL * Add changelog
* Update swedish based keymaps with newer keycodesDrashna Jaelre2019-08-30
|
* Language Keymap extras backport from ZSA fork (#6198)Drashna Jaelre2019-08-30
| | | | | | | | | | | | * Swedish extra keymap refactor * Fix swedish $ sign definition (#81) * Fix br abnt2 keymap compilation error * Add PR changelog doc * Update PR6198.md
* Add 'bootloadHID' flash target (#5587)Joel Challis2019-08-24
| | | | | | | | | | | | | | * Add 'bootloadHID' flash target * Prep for flash target * Add :flash support * Align bootloader wait messages Co-Authored-By: Drashna Jaelre <drashna@live.com> * Update template to suggest use of :flash
* Fixup Bootmagic code (#6386)Drashna Jaelre2019-08-22
|
* AVR GPIO macro defines more readable (#5937)Takeshi ISHII2019-08-21
| | | | | | | | | | | | | | | | | | | | | | * A little easier to read the definition of the GPIO control macro for AVR. No change in build result. * Changed to not use GNU statement expression extension. No change in build result. * Modified split_common/serial.c to use qmk_firmware standard GPIO control macro. No change in build result. * fix PE6 -> E6 * remove some space * add some comment to config_common.h * Changed split_common/serial.c to use a newer version of qmk_firmware standard GPIO control macro.
* Additional changes for Layer State typedef compatibility (#5906)Drashna Jaelre2019-08-21
| | | | | | | | | | | | | | | | * Additional changes for Layer State typedef compatibility * Replace biton32 with get_highest_layer in docs * Change additional layer structure code * Fix uGFX reference issue * Remove dynamic_keymap check * Where did all these extra spaces come from Co-Authored-By: fauxpark <fauxpark@gmail.com>
* Added keycodes for swapping and unswapping the Control and OS keys (#6110)Stephen Wanhella2019-08-21
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Add MAGIC_SWAP_CONTROL_LGUI and MAGIC_UNSWAP_CONTROL_LGUI keycodes Key codes to swap and unswap the control and windows/cmd keys * Fix issues with pull request #6110 Renamed swap/unswap lctl and lgui key codes, added key codes to swap/unswap rctl and rgui, and moved new bool inside keycode_config.h struct to the end * Move new keycodes to the end of the enum (#6110) * add cases for swapped control and OS keys to mod_config (#6110) * Add new keycodes to feature_bootmagic.md (#6110) * Add R+L swap codes to keep in parity with AG_* codes * Extend Magic range check to include new magic codes * Update audio docs * Combine 2 byte ranges into 1 word for EECONFG Fix names for Keymap config EEPROM * Update docs/feature_bootmagic.md Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Update docs/feature_bootmagic.md Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Update docs/feature_bootmagic.md Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Update docs/feature_bootmagic.md Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com>
* Add ATmega32U2 to mcu_selection.mk (#6561)fauxpark2019-08-17
|
* Remove backslashes from template keymap (#6548)fauxpark2019-08-17
|
* Add support for different encoder pinout for right half of split keyboard ↵Danny2019-08-16
| | | | | | | | (#6521) * Add support for different encoder pinouts for split keyboard * Update documentation for new encoder pinout feature
* Enable PWM Support for Planck EZ Indicator Lights (#6473)Drashna Jaelre2019-08-13
| | | | | | | | | | | | | | | | | | | | | | | | * remove led layer code * enable PWM on STM32F303 * Unusable PWM code * Updated PWM Stuff? * PWM Semi-working * Both LEDs working at the same time * Update names * Add led level functions * Add LED levels and persistent settings * Revert change due to issues with timing related code * Review feedback and minor cleanup
* Mask off TD() parameter properly (#6143)fauxpark2019-08-08
| | | | | | * Mask off TD() parameter properly * More parentheses
* Add some defaults for ATmega32A to mcu_selection.mk (#6253)fauxpark2019-08-08
| | | | | | | | | | | | * Add some defaults for ATmega32A to mcu_selection.mk * Remove boilerplate from templates * Relax INTERRUPT_CONTROL_ENDPOINT and PROGRAM_CMD * Apply suggestions from code review Co-Authored-By: Drashna Jaelre <drashna@live.com>
* Rename QK_TMK(_MAX) to QK_BASIC (#6509)fauxpark2019-08-08
|
* Improve backlight PWM pin support (#6202)fauxpark2019-08-08
| | | | | | | | | | | | | | | | * Improve backlight PWM pin support * I accidentally an equals sign * Another typo * Order by pin number * Throw an error if backlight pin is C4 or C5 on 16/32U4 * Use else for clarity * Minor alignment adjustments
* MIDI: Fix basic noteon: send correct velocity (#6476)Zach DeCook2019-08-06
|
* [Split] Add config option for DIRECT_PINS_RIGHT (#6479)Garrett Singer2019-08-03
| | | Adds support for different direct pin mappings on the halves of a split keyboard.
* Fix RGB Matrix Cycle Left-Right Animation (#6421)yrdns2019-07-26
| | | | | One-line fix for a typo that could break build if DISABLE_RGB_MATRIX_CYCLE_LEFT_RIGHT was defined but not DISABLE_RGB_MATRIX_CYCLE_ALL
* Remove NO_BACKLIGHT_CLOCK (#6418)fauxpark2019-07-27
|
* Fix MATRIX_X_PINS_RIGHT ARM compilation (#6395)Joel Challis2019-07-23
|
* Refactoring wilba.tech PCBs, updating Rama Works U80-A (#6272)Wilba2019-07-21
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Added WT65-B, WT75-B, minor fixes * Update keyboards/wilba_tech/wt65_b/config.h Co-Authored-By: Drashna Jaelre <drashna@live.com> * Update keyboards/wilba_tech/wt65_b/readme.md Co-Authored-By: fauxpark <fauxpark@gmail.com> * Update keyboards/wilba_tech/wt75_b/config.h Co-Authored-By: Drashna Jaelre <drashna@live.com> * Change DEBOUNCING_DELAY to DEBOUNCE * Change DEBOUNCING_DELAY to DEBOUNCE * Move Zeal60/Zeal65 files to keyboards/wilba_tech * Change DEBOUNCING_DELAY to DEBOUNCE * Refactoring zeal60 code to wilba_tech * Moved Rama Works PCBs to wilba_tech * Rename Rama Works files * Cleanup info.json * Cleanup readme.md * Cleanup USB device strings * U80-A RGB matrix, IS31FL3731 driver changes * Fixed #include from keyboards/zeal60