aboutsummaryrefslogtreecommitdiff
path: root/lib/database.cc
Commit message (Expand)AuthorAge
...
* lib: Simplify code flow in _resolve_message_id_to_thread_idCarl Worth2010-04-12
* lib: Fix internal documentation of _resolve_message_id_to_thread_idCarl Worth2010-04-12
* Store thread ids for messages that we haven't seen yetJames Westby2010-04-12
* Add is:<tag> as a synonym for tag:<tag> in search terms.Carl Worth2010-03-09
* lib: Rename iterator functions to prepare for reverse iteration.Carl Worth2010-03-09
* Fix printf for when uint64_t != unsigned long long intCarl Worth2010-02-09
* Switch from random to sequential thread identifiers.Carl Worth2010-02-09
* notmuch new: Print upgrade progress report as a percentage.Carl Worth2010-01-09
* lib: Split the database upgrade into two phases for safer operation.Carl Worth2010-01-09
* lib: Delete stale timestamp documents during database upgrade.Carl Worth2010-01-08
* notmuch new: Fix progress notification on database upgrade.Carl Worth2010-01-07
* lib: Implement versioning in the database and provide upgrade function.Carl Worth2010-01-07
* Prefer READ_ONLY consistently over READONLY.Carl Worth2010-01-07
* lib: Consolidate checks for read-only database.Carl Worth2010-01-07
* lib: Clarify internal documentation of _notmuch_database_filename_to_direntryCarl Worth2010-01-07
* lib: Indicate whether notmuch_database_remove_message removed anything.Carl Worth2010-01-06
* Add missing comment for NOTMUCH_STATUS_READONLY_DATABASE.Carl Worth2010-01-06
* lib: Implement new notmuch_directory_t API.Carl Worth2010-01-06
* database: Add new, public notmuch_database_remove_messageCarl Worth2010-01-06
* database: Add new find_doc_ids_for_term interface.Carl Worth2010-01-06
* database: Make find_unique_doc_id enforce uniqueness (for a debug build)Carl Worth2010-01-06
* database: Abstract _filename_to_direntry from _add_messageCarl Worth2010-01-06
* database: Allowing storing multiple filenames for a single message ID.Carl Worth2010-01-06
* database: Store mail filename as a new 'direntry' term, not as 'data'.Carl Worth2010-01-06
* database: Split _find_parent_id into _split_path and _find_directory_idCarl Worth2010-01-06
* database: Store directory path in 'data' of directory documents.Carl Worth2010-01-06
* database: Export _notmuch_database_find_parent_id for internal use.Carl Worth2010-01-06
* database: Store the parent ID for each directory document.Carl Worth2010-01-06
* database: Rename internal directory value from XTIMESTAMP to XDIRECTORY.Carl Worth2010-01-06
* database: Store directory paths as relative, not absolute.Carl Worth2010-01-06
* lib: Document that the filename is stored in the 'data' of a mail documentCarl Worth2010-01-06
* lib: Rename set/get_timestamp to set/get_directory_mtime.Carl Worth2010-01-06
* lib: Abstract the extraction of a relative path from set_filenameCarl Worth2010-01-06
* Nuke the remainings of _notmuch_message_add_thread_id.Fernando Carrijo2009-12-09
* notmuch: New function to retrieve all tags from the database.Jan Janak2009-11-26
* Add rudimentary date-based search.Carl Worth2009-11-23
* lib/database.cc: coding styleChris Wilson2009-11-22
* add_message: Use sha-1 in place of overly long message ID.Carl Worth2009-11-22
* get_timestamp: Ensure that return value is 0 in case of exception.Carl Worth2009-11-22
* Catch and optionally print about exception at database->flush.Carl Worth2009-11-22
* Print information about where Xapian exception occurred.Carl Worth2009-11-22
* Rename NOTMUCH_DATABASE_MODE_WRITABLE to NOTMUCH_DATABASE_MODE_READ_WRITECarl Worth2009-11-21
* Permit opening the notmuch database in read-only mode.Chris Wilson2009-11-21
* add_message: Re-fix handling of non-mail files.Carl Worth2009-11-20
* notmuch_database_add_message: Add missing error-value propagation.Carl Worth2009-11-20
* add_message: Properly handle missing Message-ID once again.Carl Worth2009-11-20
* TypsosIngmar Vanhassel2009-11-18
* linke_message: Avoid segfault when In-Reply-to header is empty.Carl Worth2009-11-18
* database: Make _parse_message_id static once again.Carl Worth2009-11-17
* database: Add "replyto" to the database schema documentation.Carl Worth2009-11-17