aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWarren Dukes <warren.dukes@gmail.com>2004-05-31 01:21:17 +0000
committerWarren Dukes <warren.dukes@gmail.com>2004-05-31 01:21:17 +0000
commitfd6aa253594e18877ca2380961c0425a7de21b2e (patch)
treeb86fc645573adef9c0de9bd5f22eadffe3d16814 /src/Makefile.am
parentd7893a3e76d261b33b83fd9333d85892b3308594 (diff)
mp3 and ogg plugin stuff
git-svn-id: https://svn.musicpd.org/mpd/trunk@1245 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5f783e6a..ead005df 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,21 +1,24 @@
bin_PROGRAMS = mpd
SUBDIRS = $(ID3_SUBDIR) $(MAD_SUBDIR) $(MP4FF_SUBDIR)
+
+mpd_inputPlugins = inputPlugins/mp3_plugin.c inputPlugins/ogg_plugin.c
+
mpd_headers = buffer2array.h interface.h command.h playlist.h ls.h \
- song.h list.h directory.h tables.h utils.h path.h mp3_decode.h \
- tag.h player.h listen.h conf.h ogg_decode.h volume.h flac_decode.h \
+ song.h list.h directory.h tables.h utils.h path.h \
+ tag.h player.h listen.h conf.h volume.h flac_decode.h \
audio.h playerData.h stats.h myfprintf.h sig_handlers.h decode.h log.h \
audiofile_decode.h charConv.h permission.h mpd_types.h pcm_utils.h \
mp4_decode.h aac_decode.h signal_check.h utf8.h inputStream.h \
outputBuffer.h replayGain.h inputStream_file.h inputStream_http.h \
inputPlugin.h
mpd_SOURCES = main.c buffer2array.c interface.c command.c playlist.c ls.c \
- song.c list.c directory.c tables.c utils.c path.c mp3_decode.c \
- tag.c player.c listen.c conf.c ogg_decode.c volume.c flac_decode.c \
+ song.c list.c directory.c tables.c utils.c path.c \
+ tag.c player.c listen.c conf.c volume.c flac_decode.c \
audio.c playerData.c stats.c myfprintf.c sig_handlers.c decode.c log.c \
audiofile_decode.c charConv.c permission.c pcm_utils.c mp4_decode.c \
aac_decode.c signal_check.c utf8.c inputStream.c outputBuffer.c \
replayGain.c inputStream_file.c inputStream_http.c inputPlugin.c \
- $(mpd_headers)
+ $(mpd_headers) $(mpd_inputPlugins)
mpd_CFLAGS = $(MPD_CFLAGS)
mpd_LDADD = $(MPD_LIBS) $(ID3_LIB) $(MAD_LIB) $(MP4FF_LIB)