aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2012-09-25 10:41:39 +0200
committerMax Kellermann <max@duempel.org>2012-09-25 10:41:39 +0200
commitc93a28c641be7c89fee5a00f11cbfec14d8f71d8 (patch)
tree19de4c585f9f85bf3fac8a1a004dff1a9ca1442d /configure.ac
parent7088a679a25cc62424b532ca47a6c13f62eb04a0 (diff)
configure.ac: don't auto-detect the Vorbis encoder when Tremor is enabled
libvorbisidec and libvorbis export the same symbols, which is a dangerous thing. Since libvorbisenc depends on libvorbis, this can get nasty, so let's disable the Vorbis encoder unless the user explicitly wants it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f9062934..87106a4f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -999,6 +999,11 @@ if test x$enable_tremor = xyes; then
AC_MSG_WARN(["OggTremor detected, could not enable Vorbis."])
fi
enable_vorbis=no
+
+ if test x$enable_vorbis_encoder = xauto; then
+ AC_MSG_WARN([OggTremor detected, disabling the Vorbis encoder plugin.])
+ enable_vorbis_encoder=no
+ fi
fi
MPD_AUTO_PKG(vorbis, VORBIS, [vorbis vorbisfile ogg],