aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-01-02 19:19:40 +0100
committerMax Kellermann <max@duempel.org>2013-01-02 19:19:58 +0100
commit83c7e1e129b1250bc73bf75e9378dfbe242b09c7 (patch)
treeecdd51df92a8b028e418a0375bd48fbd43d88a84 /configure.ac
parenta6371e2e664e4bc1ff78d881cfd2c9b5fa3909e8 (diff)
configure.ac: disable C++ RTTI
RTTI adds overhead to the binary, and we don't need that.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 305b2130..9ade4bdf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1542,6 +1542,7 @@ if test "x$enable_debug" = xno; then
AX_APPEND_COMPILE_FLAGS([-fno-threadsafe-statics])
AX_APPEND_COMPILE_FLAGS([-fmerge-all-constants])
AX_APPEND_COMPILE_FLAGS([-fno-exceptions])
+ AX_APPEND_COMPILE_FLAGS([-fno-rtti])
AC_LANG_POP
AX_APPEND_LINK_FLAGS([-Wl,--gc-sections])