aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-01-02 19:12:27 +0100
committerMax Kellermann <max@duempel.org>2013-01-02 19:12:27 +0100
commita6371e2e664e4bc1ff78d881cfd2c9b5fa3909e8 (patch)
tree39da37ce46f6874f17267b00de099e87a235486c /configure.ac
parent7768baa4d13ca508080bb95fe58fe62e7ef69ee9 (diff)
configure.ac: disable C++ exceptions
We don't use exceptions currently. Since allowing exceptions means a lot of overhead, this commit disables the feature.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ae242951..305b2130 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1541,6 +1541,7 @@ if test "x$enable_debug" = xno; then
AX_APPEND_COMPILE_FLAGS([-fvisibility=hidden])
AX_APPEND_COMPILE_FLAGS([-fno-threadsafe-statics])
AX_APPEND_COMPILE_FLAGS([-fmerge-all-constants])
+ AX_APPEND_COMPILE_FLAGS([-fno-exceptions])
AC_LANG_POP
AX_APPEND_LINK_FLAGS([-Wl,--gc-sections])