aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2012-07-30 11:10:04 +0200
committerMax Kellermann <max@duempel.org>2012-07-30 11:10:04 +0200
commit18da582c875bc331aa91efcd1969219f4406706d (patch)
tree9866e958b55707441da8a32cb67e37ce7a084c5a /configure.ac
parent0562cf99ba907f10c7d28b0bb6dd2d846e0947b8 (diff)
configure.ac: replace MPD_CHECK_FLAG with autoconf-archive scripts
Use standard scripts instead of MPD's custom implementation.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 9 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index fffef3fc..c961d101 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1499,15 +1499,15 @@ fi
dnl ----------------------------------- GCC -----------------------------------
if test x$GCC = xyes
then
- MPD_CHECK_FLAG([-Wall])
- MPD_CHECK_FLAG([-Wextra])
- MPD_CHECK_FLAG([-Wmissing-prototypes])
- MPD_CHECK_FLAG([-Wshadow])
- MPD_CHECK_FLAG([-Wpointer-arith])
- MPD_CHECK_FLAG([-Wstrict-prototypes])
- MPD_CHECK_FLAG([-Wcast-qual])
- MPD_CHECK_FLAG([-Wwrite-strings])
- MPD_CHECK_FLAG([-pedantic])
+ AX_APPEND_COMPILE_FLAGS([-Wall])
+ AX_APPEND_COMPILE_FLAGS([-Wextra])
+ AX_APPEND_COMPILE_FLAGS([-Wmissing-prototypes])
+ AX_APPEND_COMPILE_FLAGS([-Wshadow])
+ AX_APPEND_COMPILE_FLAGS([-Wpointer-arith])
+ AX_APPEND_COMPILE_FLAGS([-Wstrict-prototypes])
+ AX_APPEND_COMPILE_FLAGS([-Wcast-qual])
+ AX_APPEND_COMPILE_FLAGS([-Wwrite-strings])
+ AX_APPEND_COMPILE_FLAGS([-pedantic])
fi
dnl ---------------------------- warnings as errors ---------------------------