aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2011-10-09 17:58:36 +0200
committerMax Kellermann <max@duempel.org>2011-10-09 17:58:36 +0200
commit0c3a7bcf12542389adc404b591d685a5a990af49 (patch)
tree874f6fa329edbff6fdad069fcdc4a2e1ba19cd81 /configure.ac
parent389fbaaca2964c2f2c5be6b57c73bb20005e3019 (diff)
configure.ac: substitute MPCDEC_LIBS, MPCDEC_CFLAGS
Don't use MPD_LIBS, MPC_CFLAGS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 28dcf7ba..9c66bcb0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -912,10 +912,12 @@ if test x$enable_mpc = xyes; then
old_mpcdec=yes,
enable_mpc=no)])
if test x$enable_mpc = xyes; then
- AC_CHECK_LIB(mpcdec,main,
- [MPD_LIBS="$MPD_LIBS $MPCDEC_LIBS";
- MPD_CFLAGS="$MPD_CFLAGS $MPCDEC_CFLAGS";],
+ AC_CHECK_LIB(mpcdec,main,,
+ [],
enable_mpc=no)
+ else
+ MPCDEC_LIBS=""
+ MPCDEC_CFLAGS=""
fi
if test x$enable_mpc = xyes; then
AC_DEFINE(HAVE_MPCDEC,1,
@@ -932,6 +934,8 @@ if test x$enable_mpc = xyes; then
CPPFLAGS=$oldcppflags
fi
+AC_SUBST(MPCDEC_LIBS)
+AC_SUBST(MPCDEC_CFLAGS)
AM_CONDITIONAL(HAVE_MPCDEC, test x$enable_mpc = xyes)
dnl -------------------------------- Ogg Tremor -------------------------------