aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAnton Khirnov <anton@khirnov.net>2020-06-25 20:51:02 +0200
committerAnton Khirnov <anton@khirnov.net>2020-06-25 20:51:02 +0200
commitab72ad7bb19f08d78218d3558545f9f58e5b36e7 (patch)
tree7f010e85d58e5b40e0304600d1ec2a48aeaba300 /meson.build
parent62c92eea4ec4859fff5002931e2d7d562b3deb5d (diff)
Switch to external ndarray library.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 4599633..a08656a 100644
--- a/meson.build
+++ b/meson.build
@@ -11,7 +11,6 @@ lib_src = [
'ell_grid_solve.c',
'log.c',
'mg2d.c',
- 'ndarray.c',
'residual_calc.c',
'timer.c',
'transfer.c',
@@ -25,12 +24,13 @@ cc = meson.get_compiler('c')
libm = cc.find_library('m', required : false)
libcblas = cc.find_library('blas')
liblapacke = cc.find_library('lapacke')
+libndarray = cc.find_library('ndarray')
dep_tp = declare_dependency(link_args : '-lthreadpool')
dep_mpi = dependency('mpi', language: 'c')
-deps = [dep_tp, libm, libcblas, liblapacke, dep_mpi]
+deps = [dep_tp, libm, libcblas, liblapacke, libndarray, dep_mpi]
cdata = configuration_data()
cdata.set10('ARCH_X86', false)