aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAnton Khirnov <anton@khirnov.net>2019-05-23 11:39:59 +0200
committerAnton Khirnov <anton@khirnov.net>2019-05-23 11:41:31 +0200
commit5bd1bccffd411384b02ca772822d87fac126e67f (patch)
tree3a9494a87f93c4fa35063d47afdf294aa3b720aa /meson.build
parent4c972cfc352ae5ba851cae142ca6fe594d88bc04 (diff)
mg2d: add support for MPI-based multi-component solves
For the moment, only the finest component is distributed, any coarser levels are gathered to rank 0. That should change in the future.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 8f09386..4599633 100644
--- a/meson.build
+++ b/meson.build
@@ -97,7 +97,7 @@ endif
library('mg2d', lib_src, lib_obj, link_args : ver_flag, dependencies : deps, link_depends : verscript)
# test programs
-test_progs = ['relax', 'relax_mpi', 'mg2d']
+test_progs = ['relax', 'relax_mpi', 'mg2d', 'mg2d_mpi']
foreach t : test_progs
target = t + '_test'
executable(target, [target + '.c'] + lib_src, lib_obj, dependencies : deps + [libm])