aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAnton Khirnov <anton@khirnov.net>2019-03-18 10:33:46 +0100
committerAnton Khirnov <anton@khirnov.net>2019-03-18 10:33:46 +0100
commit457d8274fde5d20dc5694576b99c5541e55b4f40 (patch)
treeca1df761a0340bcc1bd5324895d8067d3b8528e6 /meson.build
parent53e7613a1111702bb62708d1e5aff8b18fa9c9cb (diff)
ell_grid_solve: use BiCGSTAB to speed up exact solves
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 48d80ef..73dfee9 100644
--- a/meson.build
+++ b/meson.build
@@ -4,6 +4,7 @@ project('libmg2d', 'c',
add_project_arguments('-D_XOPEN_SOURCE=700', language : 'c')
lib_src = [
+ 'bicgstab.c',
'boundary.c',
'cpu.c',
'ell_grid_solve.c',
@@ -18,11 +19,12 @@ ver_flag = '-Wl,--version-script,@0@/@1@'.format(meson.current_source_dir(), ve
cc = meson.get_compiler('c')
libm = cc.find_library('m', required : false)
+libcblas = cc.find_library('blas')
liblapacke = cc.find_library('lapacke')
dep_tp = declare_dependency(link_args : '-lthreadpool')
-deps = [dep_tp, libm, liblapacke]
+deps = [dep_tp, libm, libcblas, liblapacke]
cdata = configuration_data()
cdata.set10('ARCH_X86', false)