summaryrefslogtreecommitdiff
path: root/libavfilter/vf_gradfun.c
Commit message (Collapse)AuthorAge
* cosmetics: Fix spelling mistakesVittorio Giovara2016-05-04
| | | | Signed-off-by: Diego Biurrun <diego@biurrun.de>
* lavfi: Use AV_CEIL_RSHIFT where neededVittorio Giovara2016-01-25
|
* avfilter: Add missing emms_c when neededLuca Barbato2014-03-05
| | | | | | | | Arch specific calls should have an emms_c following to keep the cpu state consistent. Reported-By: wm4 CC: libav-stable@libav.org
* lavfi: do not export the filters from shared objectsAnton Khirnov2013-10-28
|
* avfilter: Fix typo in Loren's email addressDiego Biurrun2013-10-23
|
* avisynth: Fix a "AVISynth" vs. "AviSynth" struct name typoDiego Biurrun2013-07-29
| | | | Also fix some similar typos in comments and documentation.
* vf_gradfun: make config_props work properly when called multiple times.Anton Khirnov2013-05-17
|
* vf_gradfun: use the name 's' for the pointer to the private contextAnton Khirnov2013-05-16
| | | | This is shorter and consistent across filters.
* lavfi: remove now unused args parameter from AVFilter.initAnton Khirnov2013-04-09
|
* vf_gradfun: switch to an AVOptions-based system.Anton Khirnov2013-04-09
|
* lavfi/gradfun: fix rounding in MMX code.Clément Bœsch2013-03-28
| | | | | | | | | | | | | | | Current code divides before increasing precision. Also reduce upper bound for strength from 255 to 64. This will prevent an overflow in the SSSE3 and MMX filter_line code: delta is expressed as an u16 being shifted by 2 to the left. If it overflows, having a strength not above 64 will make sure that m is set to 0 (making the m*m*delta >> 14 expression void). A value above 64 should not make any sense unless gradfun is used as a blur filter. Signed-off-by: Anton Khirnov <anton@khirnov.net>
* lavfi/gradfun: do not increment DC pointer for odd values.Clément Bœsch2013-03-28
| | | | | | | First DC is only used once otherwise. This also makes the code consistent with ASM versions. Signed-off-by: Anton Khirnov <anton@khirnov.net>
* vf_gradfun: fix uninitialized variable useAnton Khirnov2013-03-11
| | | | CC:libav-stable@libav.org
* lavfi: switch to AVFrame.Anton Khirnov2013-03-08
| | | | | Deprecate AVFilterBuffer/AVFilterBufferRef and everything related to it and use AVFrame instead.
* lavfi: merge start_frame/draw_slice/end_frameAnton Khirnov2012-11-28
| | | | | Any alleged performance benefits gained from the split are purely mythological and do not justify added code complexity.
* avfilter: call x86 init functions under if (ARCH_X86), not if (HAVE_MMX)Diego Biurrun2012-10-12
|
* lavfi: do not use av_pix_fmt_descriptors directly.Anton Khirnov2012-10-12
|
* lavfi: convert input/ouput list compound literals to named objectsMans Rullgard2012-10-10
| | | | | | | A number of compilers, for example those from TI and IBM, choke on these initialisers. The current style is also quite ugly. Signed-off-by: Mans Rullgard <mans@mansr.com>
* Replace PIX_FMT_* -> AV_PIX_FMT_*, PixelFormat -> AVPixelFormatAnton Khirnov2012-10-08
|
* Don't include common.h from avutil.hMartin Storsjö2012-08-15
| | | | Signed-off-by: Martin Storsjö <martin@martin.st>
* factor identical ff_inplace_start_frame out of two filtersLoren Merritt2012-07-28
| | | | Signed-off-by: Ronald S. Bultje <rsbultje@gmail.com>
* lavfi: check all avfilter_ref_buffer() calls for errors.Anton Khirnov2012-07-22
|
* lavfi: add error handling to end_frame().Anton Khirnov2012-07-22
|
* lavfi: add error handling to draw_slice().Anton Khirnov2012-07-22
|
* lavfi: add error handling to start_frame().Anton Khirnov2012-07-22
|
* lavfi: use const for AVFilterPad declarations in all filters.Ronald S. Bultje2012-07-21
|
* lavfi: unref AVFilterLink.out_buf in ff_end_frame().Anton Khirnov2012-07-20
| | | | | This reduces code duplication and prevents stale pointers from remaining on the link.
* lavfi: unref AVFilterLink.cur_buf in ff_end_frame().Anton Khirnov2012-07-20
| | | | | This reduces code duplication and prevents stale pointers from remaining on the link.
* vf_gradfun: don't store two pointers to one AVFilterBufferRef.Anton Khirnov2012-07-20
|
* vf_gradfun: move x86 init code to x86/gradfun.cMans Rullgard2012-07-02
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* lavfi: make filters less verbose.Anton Khirnov2012-06-26
|
* lavfi: remove 'opaque' parameter from AVFilter.init()Anton Khirnov2012-06-26
| | | | | | It is not used in any filters currently and is inherently evil. If passing binary data to filters is required in the future, it should be done with some AVOptions-based system.
* lavfi: make AVFilterPad opaque after two major bumps.Anton Khirnov2012-06-13
| | | | It will allow adding new fields to it without ABI breaks.
* lavfi: make avfilter_get_video_buffer() private on next bump.Anton Khirnov2012-06-13
| | | | | They are only useful inside filters and we don't allow user filters for now.
* lavfi: remove request/poll and drawing functions from public API on next bumpAnton Khirnov2012-06-05
| | | | | They are only useful inside filters and we don't allow user filters for now.
* lavfi: make formats API private on next bump.Anton Khirnov2012-06-05
| | | | | It is only useful inside filters and we don't allow user filters for now.
* Drop some completely unnecessary av_unused attributes.Diego Biurrun2012-02-13
|
* Replace FFmpeg with Libav in licence headersMans Rullgard2011-03-19
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* Merge libavcore into libavutilReinhard Tartler2011-02-15
| | | | | | | | | | | | It is pretty hopeless that other considerable projects will adopt libavutil alone in other projects. Projects that need small footprint are better off with more specialized libraries such as gnulib or rather just copy the necessary parts that they need. With this in mind, nobody is helped by having libavutil and libavcore split. In order to ease maintenance inside and around FFmpeg and to reduce confusion where to put common code, avcore's functionality is merged (back) to avutil. Signed-off-by: Reinhard Tartler <siretart@tauware.de>
* Fix crash in gradfun:end_frame() when inpic == outpic, so it has to beStefano Sabatini2010-12-19
| | | | | | freed just once. Originally committed as revision 26058 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add gradfun filter, ported from MPlayer.Nolan L2010-12-12
Patch by Nolan L nol888 <=> gmail >=< com. See thread: Subject: [FFmpeg-devel] [PATCH] Port gradfun to libavfilter (GCI) Date: Mon, 29 Nov 2010 07:18:14 -0500 Originally committed as revision 25942 to svn://svn.ffmpeg.org/ffmpeg/trunk