summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
authorschnetter <schnetter@17b73243-c579-4c4c-a9d2-2d5706c11dac>2005-10-12 11:09:52 +0000
committerschnetter <schnetter@17b73243-c579-4c4c-a9d2-2d5706c11dac>2005-10-12 11:09:52 +0000
commit8333cb2f5989287f11d00464dfc8694c6ae3e775 (patch)
treed667a5e9eadfc7492d4040b48bc393816422f214 /lib/make/configure.in
parente33cd9fc666dcbe0a03a4642321bb00f9fb1491b (diff)
Cactus overrides the user's setting of F77 with that of F90. It also
overrides F77FLAGS with F90FLAGS. This patch also sets F77_DEBUG_FLAGS and F77_OPTIMISE_FLAGS from the corresponding F90 flag settings. git-svn-id: http://svn.cactuscode.org/flesh/trunk@4183 17b73243-c579-4c4c-a9d2-2d5706c11dac
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index e0b6fc74..fce849fe 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -203,7 +203,9 @@ CCTK_WriteLine cctk_Archdefs.h '#endif /* _CCTK_ARCHDEFS_H_ */'
# If there's a Fortran 90 compiler use that for all the Fortran.
if test "x$F90" != 'x' -a "x$F90" != 'xnone' -a "x$F77" != 'xnone' ; then
F77=$F90
- : {F77FLAGS=$F90FLAGS}
+ F77FLAGS=$F90FLAGS
+ F77_DEBUG_FLAGS=$F90_DEBUG_FLAGS
+ F77_OPTIMISE_FLAGS=$F90_OPTIMISE_FLAGS
fi
# The known architecture stuff has probably set the LIBS variable