summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
authorgoodale <goodale@17b73243-c579-4c4c-a9d2-2d5706c11dac>2005-10-11 14:34:31 +0000
committergoodale <goodale@17b73243-c579-4c4c-a9d2-2d5706c11dac>2005-10-11 14:34:31 +0000
commite33cd9fc666dcbe0a03a4642321bb00f9fb1491b (patch)
tree3e00d875bd940f33eff73517e8e0492af9f2d2a8 /lib/make/configure.in
parent83f469deb9369f71f3c5bccb9ce89dce070b22b2 (diff)
Re-instating the configure test for X, but protecting it in
an if clause so it is only tested if CCTK_NEED_X is true. The PETSc extras file has been updated to set this flag. This will be reverted when the extras stuff is removed and thorns are using the thorns in CactusExternal to detect things. git-svn-id: http://svn.cactuscode.org/flesh/trunk@4182 17b73243-c579-4c4c-a9d2-2d5706c11dac
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in25
1 files changed, 13 insertions, 12 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index 01e58ff6..e0b6fc74 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -311,18 +311,6 @@ else
CCTK_FIND_NULLDEVICE
fi
-# Find the X libraries in case people need them
-# Commented out as should now be able able to use configure.ccl scripts
-# to do this on an individual basis.
-
-dnl AC_PATH_X
-
-dnl AC_SUBST(X_LIB_DIR)
-dnl AC_SUBST(X_INC_DIR)
-
-dnl X_LIB_DIR="$x_libraries"
-dnl X_INC_DIR="$x_includes"
-
# Various flags
AC_SUBST(ARFLAGS)
@@ -1024,6 +1012,19 @@ do
fi
done
+# Find the X libraries in case people need them
+# Commented out as should now be able able to use configure.ccl scripts
+# to do this on an individual basis.
+
+if test "x$CCTK_NEED_X" = 'xyes' ; then
+AC_PATH_X
+fi
+AC_SUBST(X_LIB_DIR)
+AC_SUBST(X_INC_DIR)
+
+X_LIB_DIR="$x_libraries"
+X_INC_DIR="$x_includes"
+
# Finish the cctk_Extradefs.h file
CCTK_WriteLine cctk_Extradefs.h '#endif /*_CCTK_EXTRADEFS_H*/'