summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnton Khirnov <anton@khirnov.net>2020-02-08 13:56:56 +0100
committerAnton Khirnov <anton@khirnov.net>2020-02-19 16:00:44 +0100
commitd25d788bdcf91f4066ae8e80ef7aebe85213d4d3 (patch)
treef0b35cfdd0fbeb36af971a6ea640f145771d16aa /setup.py
parent48dac1d9089ce2a36c55dc4768b24293d1257a37 (diff)
thread: drop the use of urwidtrees
Their API is misdesigned - forces the use of trees for nontree objects and mixes data relationships with display properties. The result is a mess that is hard to understand/maintain/extend. Replace the use of urwidtrees with urwid Pile and ListBox. This temporarily removes tree-style indentation and decorations for thread buffers. That will be reimplemented in following commits.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 0 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 5e95cd3e..67628890 100755
--- a/setup.py
+++ b/setup.py
@@ -46,7 +46,6 @@ setup(
install_requires=[
'notmuch>=0.27',
'urwid>=1.3.0',
- 'urwidtrees>=1.0',
'twisted>=18.4.0',
'python-magic',
'configobj>=4.7.0',