summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPatrick Totzke <patricktotzke@gmail.com>2012-02-01 08:17:51 +0000
committerPatrick Totzke <patricktotzke@gmail.com>2012-02-01 08:17:51 +0000
commitb9b6644ae32d3d489dfe8ca61854dc26bcc75822 (patch)
tree5f71b465ce98badcea0712d059f212ffb0e45372 /setup.py
parenta049ec2fed898d8c828de74c8f4449f2378c9545 (diff)
revert to hardcoded version strings
before, we tried to be smart and wrote an auto-generated version string via `git describe` to alot.VERSION at setup time that got read by alot.__init__ later on. This reverts to a hardcoded version string in alot.__version__. It makes tedious calls to `git update-index --assume-unchanged VERSION` unnecessary and makes life easier for packagers. closes issue #299
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 3 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index f52940ba..62110fdd 100755
--- a/setup.py
+++ b/setup.py
@@ -4,18 +4,16 @@ from distutils.core import setup
import alot
-
setup(name='alot',
- version=alot.version.generate_version(),
+ version=alot.__version__,
description=alot.__description__,
author=alot.__author__,
author_email=alot.__author_email__,
url=alot.__url__,
+ license=alot.__copyright__,
packages=['alot', 'alot.commands'],
- package_data={'alot': ['defaults/alot.rc', 'defaults/notmuch.rc',
- 'VERSION']},
+ package_data={'alot': ['defaults/alot.rc', 'defaults/notmuch.rc']},
scripts=['bin/alot'],
- license=alot.__copyright__,
requires=[
'notmuch (>=0.9)',
'argparse (>=2.7)',