summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPatrick Totzke <patricktotzke@gmail.com>2012-01-07 11:07:23 +0000
committerPatrick Totzke <patricktotzke@gmail.com>2012-01-07 11:07:23 +0000
commita255d407a4e94136b57971e4bb4c9fe014c9c4b5 (patch)
tree0a24e353d95ef953a9d172f19d06a9228c49c964 /setup.py
parent06224ad44b7369915b32e87ad0fe102a12949191 (diff)
make sure __init__ only reads the VERSION file
and never writes it. The file /alot/VERSION will be provided in the future and contain the release version string. setup.py will try to overwrite this with the result of `git describe` which will suceed only if we are on a git checkout.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 1ea04992..45f72cd0 100755
--- a/setup.py
+++ b/setup.py
@@ -4,8 +4,9 @@ from distutils.core import setup
import alot
+
setup(name='alot',
- version=alot.__version__,
+ version=alot.version.read_version(),
description=alot.__description__,
author=alot.__author__,
author_email=alot.__author_email__,