summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPatrick Totzke <patricktotzke@gmail.com>2011-12-14 12:11:26 +0000
committerPatrick Totzke <patricktotzke@gmail.com>2011-12-16 22:14:17 +0000
commit9afecc45f0ff3e68e751a10f3f6485776b780f4d (patch)
tree82c765877e5634e57a275b47bb9a8c080f4f7692 /setup.py
parente5344317d3b69475239c4793463dceb30cbc6433 (diff)
atomagic version string generation
http://dcreager.net/2010/02/10/setuptools-git-version-numbers/ Also makes the version string accessible as alot.__version__.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 6d7340ae..93d1f18d 100755
--- a/setup.py
+++ b/setup.py
@@ -3,6 +3,7 @@
from distutils.core import setup
import alot
+
setup(name='alot',
version=alot.__version__,
description=alot.__description__,
@@ -10,7 +11,8 @@ setup(name='alot',
author_email=alot.__author_email__,
url=alot.__url__,
packages=['alot', 'alot.commands'],
- package_data={'alot': ['defaults/alot.rc', 'defaults/notmuch.rc']},
+ package_data={'alot': ['defaults/alot.rc', 'defaults/notmuch.rc',
+ 'VERSION']},
scripts=['bin/alot'],
license=alot.__copyright__,
requires=[
@@ -19,6 +21,5 @@ setup(name='alot',
'urwid (>=1.0)',
'twisted (>=10.2.0)',
'subprocess (>=2.7)'],
- provides='alot'
+ provides='alot',
)
-