summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMartin Zimmermann <info@posativ.org>2014-06-29 22:43:34 +0200
committerPatrick Totzke <patricktotzke@gmail.com>2015-02-23 14:31:24 +0000
commit5a3eb2a5fcaec6c82c85391f22e4f275812b8432 (patch)
tree4558bcbec503c851da05e70017f15584a73e4fd9 /setup.py
parent3faa11557a6cc58b8d2e3a7ff90535e73399da7b (diff)
switch to setuptools
* use entrypoint to generate executable * find_packages() automatically includes all modules * requires -> install_requires (remove argparse and subprocess, argparse is included in Python 2.7, subprocess had some missing functionality before 2.7) Conflicts: setup.py
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py53
1 files changed, 23 insertions, 30 deletions
diff --git a/setup.py b/setup.py
index a6effb5e..6cd0e30b 100755
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
#!/usr/bin/env python
-from distutils.core import setup
+from setuptools import setup, find_packages
import alot
@@ -11,34 +11,27 @@ setup(name='alot',
author_email=alot.__author_email__,
url=alot.__url__,
license=alot.__copyright__,
- packages=[
- 'alot',
- 'alot.commands',
- 'alot.settings',
- 'alot.db',
- 'alot.utils',
- 'alot.widgets',
- ],
- package_data={
- 'alot': [
- 'defaults/alot.rc.spec',
- 'defaults/notmuch.rc.spec',
- 'defaults/abook_contacts.spec',
- 'defaults/default.theme',
- 'defaults/default.bindings',
- 'defaults/config.stub',
- 'defaults/theme.spec',
- ]},
- scripts=['bin/alot'],
- requires=[
- 'notmuch (>=0.13)',
- 'argparse (>=2.7)',
- 'urwid (>=1.1.0)',
- 'urwidtrees (>=1.0)',
- 'twisted (>=10.2.0)',
- 'magic',
- 'configobj (>=4.6.0)',
- 'subprocess (>=2.7)',
- 'gpgme (>=0.2)'],
+ packages=find_packages(),
+ package_data={'alot': [
+ 'defaults/alot.rc.spec',
+ 'defaults/notmuch.rc.spec',
+ 'defaults/abook_contacts.spec',
+ 'defaults/default.theme',
+ 'defaults/default.bindings',
+ 'defaults/config.stub',
+ 'defaults/theme.spec',
+ ]},
+ entry_points={
+ 'console_scripts':
+ ['alot = alot.init:main'],
+ },
+ install_requires=[
+ 'notmuch>=0.13',
+ 'urwid>=1.1.0',
+ 'urwidtrees (>=1.0)',
+ 'twisted>=10.2.0',
+ 'python-magic',
+ 'configobj>=4.6.0',
+ 'pygpgme>=0.2'],
provides='alot',
)