summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPatrick Totzke <patricktotzke@gmail.com>2012-07-31 21:34:49 +0100
committerPatrick Totzke <patricktotzke@gmail.com>2012-08-01 07:56:12 +0100
commit21d106c1dfb0c1ef7c743490178d1b7447b2b7c9 (patch)
treef4c1b54b11c7aff71177e5bba97c408238500182 /setup.py
parent8bcd5560af59e2476272e64559d7461ec7247342 (diff)
read default bindings from default/default.bindings
This re-introduces a separate file containing the default keybindings for alot. The values from this file are *always* used as fallbacks and can be overwritten by bindings from the users config. To be able to unbind a default binding just bind it to an empty string. The same will allow buffer-local bindings to be overwritten by global bindings as described in https://github.com/pazz/alot/issues/403#issuecomment-4434948. cf issue #487
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index cb0d5447..c754eeed 100755
--- a/setup.py
+++ b/setup.py
@@ -18,6 +18,7 @@ setup(name='alot',
'defaults/notmuch.rc.spec',
'defaults/abook_contacts.spec',
'defaults/default.theme',
+ 'defaults/default.bindings',
'defaults/config.stub',
'defaults/theme.spec',
]},