summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-03-06 15:32:50 -0800
committerDylan Baker <dylan@pnwbakers.com>2018-03-06 16:41:51 -0800
commit0b5f8bf143e76be7ac989e8c8ec6e4a7dc08a78a (patch)
tree4e91c271764d7ae99a17bf26bd124825182190bc /setup.py
parent637a1b44186612dc1119454eb1a2cffe20c0da40 (diff)
require chardet
magic struggles to decode a number of encodings, particularly it struggles with windows-1252, which Exchange *loves* to silently re-encode mail in, without updated the charset of the payload. Chardet successfully guesses these oddball encodings much more often.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 5a798160..26efe9e8 100755
--- a/setup.py
+++ b/setup.py
@@ -48,7 +48,8 @@ setup(
'twisted>=10.2.0',
'python-magic',
'configobj>=4.7.0',
- 'gpg'
+ 'gpg',
+ 'chardet',
],
tests_require=[
'mock',