summaryrefslogtreecommitdiff
path: root/alot/defaults/alot.rc.spec
diff options
context:
space:
mode:
authorLucas Hoffmann <l-m-h@web.de>2016-03-11 12:42:10 +0100
committerPatrick Totzke <patricktotzke@gmail.com>2016-03-24 21:01:43 +0000
commit9692d9c3b5729ff645f6586c526463725b6e291b (patch)
treebd7e477e1a121df37bb6742583c1aeaed868b27b /alot/defaults/alot.rc.spec
parent53f5a637ed07c47e57e25c803caf7bc1b06c4e7f (diff)
Make encrypt_by_default a three choice option.
The new specs for the config file are defined to allow existing config files to work with it.
Diffstat (limited to 'alot/defaults/alot.rc.spec')
-rw-r--r--alot/defaults/alot.rc.spec19
1 files changed, 16 insertions, 3 deletions
diff --git a/alot/defaults/alot.rc.spec b/alot/defaults/alot.rc.spec
index a02fecd5..00173d47 100644
--- a/alot/defaults/alot.rc.spec
+++ b/alot/defaults/alot.rc.spec
@@ -229,7 +229,7 @@ prefer_plaintext = boolean(default=False)
# messages in that thread.
msg_summary_hides_threadwide_tags = boolean(default=True)
-# Key bindings
+# Key bindings
[bindings]
__many__ = string(default=None)
[[___many___]]
@@ -299,8 +299,21 @@ msg_summary_hides_threadwide_tags = boolean(default=True)
# Outgoing messages will be GPG signed by default if this is set to True.
sign_by_default = boolean(default=False)
- # Outgoing messages will be GPG encrypted by default if this is set to True.
- encrypt_by_default = boolean(default=False)
+ # Alot will try to GPG encrypt outgoing messages by default when this
+ # is set to `True` or `Valid`. If set to `True` the message will be
+ # encrypted for all recipients if a key for all of them is available
+ # in the key ring. If set to `Valid` it will be encrypted to all
+ # recipients if a valid key is available for all recipients.
+ # Otherwise (at least one key not available or not valid) the message
+ # will not be encrypted by default.
+ #
+ # .. note:: If the message will not be encrypted by default you can
+ # still use the :ref:`toggleencrypt
+ # <cmd.envelope.toggleencrypt>`, :ref:`encrypt
+ # <cmd.envelope.encrypt>` and :ref:`unencrypt
+ # <cmd.envelope.unencrypt>` commands to encrypt it.
+
+ encrypt_by_default = option('Valid', True, False, default=False)
# The GPG key ID you want to use with this account. If unset, alot will
# use your default key.