summaryrefslogtreecommitdiff
path: root/alot/defaults/alot.rc.spec
diff options
context:
space:
mode:
authorPatrick Totzke <patricktotzke@gmail.com>2012-06-19 22:36:04 +0100
committerPatrick Totzke <patricktotzke@gmail.com>2012-06-19 22:36:04 +0100
commit762ca75898ed7ab5f7ba65308077f5f86b8dcee0 (patch)
treef5497973453670321e5a35c1eb2b9119478352d7 /alot/defaults/alot.rc.spec
parent0f3e9b0e2d6f872de97532689bc8c7bc27221d60 (diff)
add MODE_statusbar config options
for configurable status bar on a per-mode basis. This also adds their docs
Diffstat (limited to 'alot/defaults/alot.rc.spec')
-rw-r--r--alot/defaults/alot.rc.spec42
1 files changed, 42 insertions, 0 deletions
diff --git a/alot/defaults/alot.rc.spec b/alot/defaults/alot.rc.spec
index e1996b32..f776da72 100644
--- a/alot/defaults/alot.rc.spec
+++ b/alot/defaults/alot.rc.spec
@@ -82,6 +82,48 @@ notify_timeout = integer(default=2)
# display status-bar at the bottom of the screen?
show_statusbar = boolean(default=True)
+# Format of the status-bar in bufferlist mode.
+# This is a pair of strings to be left and right aligned in the status-bar that may contain variables:
+#
+# * `{buffer_no}`: index of this buffer in the global buffer list
+# * `{total_messages}`: total numer of messages indexed by notmuch
+bufferlist_statusbar = mixed_list(string, string, default=list('[{buffer_no}: bufferlist]','total messages: {total_messages}'))
+
+# Format of the status-bar in search mode.
+# This is a pair of strings to be left and right aligned in the status-bar.
+# Apart from the global variables listed at :ref:`bufferlist_statusbar <bufferlist-statusbar>`
+# these strings may contain variables:
+#
+# * `{querystring}`: search string
+# * `{result_count}`: number of matching messages
+# * `{result_count_positive}`: 's' if result count is greater than 0.
+search_statusbar = mixed_list(string, string, default=list('[{buffer_no}: search] for "{querystring}"','{result_count} of {total_messages} messages'))
+
+# Format of the status-bar in thread mode.
+# This is a pair of strings to be left and right aligned in the status-bar.
+# Apart from the global variables listed at :ref:`bufferlist_statusbar <bufferlist-statusbar>`
+# these strings may contain variables:
+#
+# * `{tid}`: thread id
+# * `{subject}`: subject line of the thread
+# * `{authors}`: abbreviated authors string for this thread
+# * `{message_count}`: number of contained messages
+thread_statusbar = mixed_list(string, string, default=list('[{buffer_no}: thread] {subject}','total messages: {total_messages}'))
+
+# Format of the status-bar in taglist mode.
+# This is a pair of strings to be left and right aligned in the status-bar.
+# These strings may contain variables listed at :ref:`bufferlist_statusbar <bufferlist-statusbar>`
+# that will be substituted accordingly.
+taglist_statusbar = mixed_list(string, string, default=list('[{buffer_no}: taglist]','total messages: {total_messages}'))
+
+# Format of the status-bar in envelope mode.
+# This is a pair of strings to be left and right aligned in the status-bar.
+# Apart from the global variables listed at :ref:`bufferlist_statusbar <bufferlist-statusbar>`
+# these strings may contain variables:
+#
+# * `{to}`: To-header of the envelope
+envelope_statusbar = mixed_list(string, string, default=list('[{buffer_no}: envelope]','total messages: {total_messages}'))
+
# timestamp format in `strftime format syntax <http://docs.python.org/library/datetime.html#strftime-strptime-behavior>`_
timestamp_format = string(default=None)