summaryrefslogtreecommitdiff
path: root/alot/defaults/alot.rc.spec
diff options
context:
space:
mode:
authorLucas Hoffmann <l-m-h@web.de>2016-03-12 02:25:04 +0100
committerPatrick Totzke <patricktotzke@gmail.com>2016-03-24 21:01:43 +0000
commit2fbef26748c1199b6a1d0024ddf1916ab7db0be8 (patch)
treeb4df7b8a69b7add787fa5f6973ec00f12f833907 /alot/defaults/alot.rc.spec
parent09c86c2e7d936eeee4ec3f50636cb38ae2510ed4 (diff)
Change possible values for new option.
Diffstat (limited to 'alot/defaults/alot.rc.spec')
-rw-r--r--alot/defaults/alot.rc.spec19
1 files changed, 11 insertions, 8 deletions
diff --git a/alot/defaults/alot.rc.spec b/alot/defaults/alot.rc.spec
index 00173d47..18b17772 100644
--- a/alot/defaults/alot.rc.spec
+++ b/alot/defaults/alot.rc.spec
@@ -300,20 +300,23 @@ msg_summary_hides_threadwide_tags = boolean(default=True)
sign_by_default = boolean(default=False)
# Alot will try to GPG encrypt outgoing messages by default when this
- # is set to `True` or `Valid`. If set to `True` the message will be
- # encrypted for all recipients if a key for all of them is available
- # in the key ring. If set to `Valid` it will be encrypted to all
- # recipients if a valid key is available for all recipients.
- # Otherwise (at least one key not available or not valid) the message
- # will not be encrypted by default.
+ # is set to `all` or `trusted`. If set to `all` the message will be
+ # encrypted for all recipients for who a key is available in the key
+ # ring. If set to `trusted` it will be encrypted to all
+ # recipients if a trusted key is available for all recipients (one
+ # where the user id for the key is signed with a trusted signature).
#
# .. note:: If the message will not be encrypted by default you can
# still use the :ref:`toggleencrypt
# <cmd.envelope.toggleencrypt>`, :ref:`encrypt
# <cmd.envelope.encrypt>` and :ref:`unencrypt
# <cmd.envelope.unencrypt>` commands to encrypt it.
-
- encrypt_by_default = option('Valid', True, False, default=False)
+ # .. note:: The values `True` and `False` are interpreted as `all` and
+ # `none` respectively. They are kept for backwards
+ # compatibility to give users a change to migrate to the new
+ # option type. They might become deprecated in future
+ # versions.
+ encrypt_by_default = option('all', 'none', 'trusted', 'True', 'False', default='none')
# The GPG key ID you want to use with this account. If unset, alot will
# use your default key.