summaryrefslogtreecommitdiff
path: root/alot/defaults/alot.rc.spec
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2017-01-25 15:52:58 -0800
committerDylan Baker <dylan@pnwbakers.com>2017-01-26 13:40:27 -0800
commit0511526d97cb6a74282c5f4dd334be1f5f355ea0 (patch)
tree7c150de01bc2e60c3194381475d124e2d582f765 /alot/defaults/alot.rc.spec
parenta2f001df1176f14bb18d82687b4c42721bd02efd (diff)
Implement a hook that runs periodically
This creates a deferred that runs on a user configurable timer and is provided the ui. This deferred will re-fire after the number of seconds specified by the timer are eclipsed. By default this is 300 seconds. Fixes #522
Diffstat (limited to 'alot/defaults/alot.rc.spec')
-rw-r--r--alot/defaults/alot.rc.spec3
1 files changed, 3 insertions, 0 deletions
diff --git a/alot/defaults/alot.rc.spec b/alot/defaults/alot.rc.spec
index d2ee450f..cd72b39c 100644
--- a/alot/defaults/alot.rc.spec
+++ b/alot/defaults/alot.rc.spec
@@ -248,6 +248,9 @@ reply_account_header_priority = force_list(default=list(From,To,Cc,Envelope-To,X
# history file might get *very* long.
history_size = integer(default=50)
+# The number of seconds to wait between calls to the loop_hook
+periodic_hook_frequency = integer(default=300)
+
# Key bindings
[bindings]
__many__ = string(default=None)