aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAnton Khirnov <anton@khirnov.net>2019-01-11 12:50:30 +0100
committerAnton Khirnov <anton@khirnov.net>2019-01-11 12:50:30 +0100
commitbb944f2958339e09a936c98f931c38e3fa3f8c5f (patch)
treed26e5d99ea08eb94a52f09f972bda1ce5af8e8fc /meson.build
Initial commit.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..c2f6c76
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,16 @@
+project('libthreadpool', 'c',
+ default_options : ['c_std=c11'])
+
+add_project_arguments('-D_XOPEN_SOURCE=700', language : 'c')
+
+lib_src = [
+ 'threadpool.c',
+]
+
+verscript = 'libthreadpool.v'
+ver_flag = '-Wl,--version-script,@0@/@1@'.format(meson.current_source_dir(), verscript)
+
+dep_omp = dependency('openmp')
+deps = [dep_omp]
+
+library('threadpool', lib_src, link_args : ver_flag, dependencies : deps)