summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Pointhuber <thomas.pointhuber@gmx.at>2014-11-18 11:37:42 +0100
committerThomas Pointhuber <thomas.pointhuber@gmx.at>2014-11-18 11:37:42 +0100
commitaba65369d2d55b337939d004b06d6ff10f8519b9 (patch)
tree0197b53f95679a4a95fa1f5e96b39b7c54748034 /setup.py
parentb1234ee88947f2ce61a7df361c706622a3ec2a32 (diff)
[enh] make version of searx readable
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index da3d1b6a..3e52e18d 100644
--- a/setup.py
+++ b/setup.py
@@ -6,6 +6,10 @@ from setuptools import find_packages
import os
+# required to load VERSION_STRING constant
+sys.path.insert(0, './searx')
+from version import VERSION_STRING
+
def read(*rnames):
return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
@@ -15,7 +19,7 @@ long_description = read('README.rst')
setup(
name='searx',
- version="0.4.0",
+ version=VERSION_STRING,
description="A privacy-respecting, hackable metasearch engine",
long_description=long_description,
classifiers=[