summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMarkus Heiser <markus.heiser@darmarit.de>2020-12-27 14:39:48 +0100
committerMarkus Heiser <markus.heiser@darmarit.de>2021-01-11 22:12:38 +0100
commit9e53470b4cf533b890a2f57debd2f2b4198b4dd1 (patch)
tree5e041304488451cba4548fd386d625dd0cabec3a /setup.py
parent9485179064b4eb28f2813eba3c295edca3b0db7f (diff)
[mod] get rid of searx/brand.py
Removes module searx/brand.py and creates a namespace at searx.brand. This patch is a first 'proof of concept'. Later we can decide to remove the brand namespace entirely or not. Signed-off-by: Markus Heiser <markus.heiser@darmarit.de>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 2 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 6a78f61b..f89f1682 100644
--- a/setup.py
+++ b/setup.py
@@ -7,10 +7,8 @@ from setuptools import find_packages
import os
import sys
-# required to load VERSION_STRING constant
-sys.path.insert(0, './searx')
-from version import VERSION_STRING
-import brand
+from searx.version import VERSION_STRING
+from searx import brand
with open('README.rst', encoding='utf-8') as f:
long_description = f.read()