summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarl Worth <cworth@cworth.org>2010-04-06 15:05:13 -0700
committerCarl Worth <cworth@cworth.org>2010-04-06 18:30:43 -0700
commitdfbec15b2388158693ab0dce0c7d348c4c5a98a5 (patch)
treee29c7fcf3a3fd23c209df1ec426494f83621c120
parent53fa1ed0a89f2965e387e41509b998dad1e7ab82 (diff)
Install emacs lisp files into a notmuch sub-directory of site-lisp.
Now that we have multiple emacs-lisp source files, it's just more polite this way.
-rwxr-xr-xconfigure15
-rw-r--r--debian/notmuch.install1
-rw-r--r--emacs/Makefile.local6
3 files changed, 13 insertions, 9 deletions
diff --git a/configure b/configure
index fcaa373..21780a6 100755
--- a/configure
+++ b/configure
@@ -71,6 +71,7 @@ Fine tuning of some installation directories is available:
--includedir=DIR Install header files to DIR [PREFIX/include]
--mandir=DIR Install man pages to DIR [PREFIX/share/man]
--sysconfdir=DIR Read-only single-machine data [PREFIX/etc]
+ --emacslispdir=DIR Elisp [PREFIX/share/emacs/site-lisp/notmuch]
Additional options are accepted for compatibility with other
configure-script calling conventions, but don't do anything yet:
@@ -100,6 +101,8 @@ for option; do
MANDIR="${option#*=}"
elif [ "${option%%=*}" = '--sysconfdir' ] ; then
SYSCONFDIR="${option#*=}"
+ elif [ "${option%%=*}" = '--emacslispdir' ] ; then
+ EMACSLISPDIR="${option#*=}"
elif [ "${option%%=*}" = '--build' ] ; then
build_option="${option#*=}"
case ${build_option} in
@@ -214,10 +217,12 @@ else
have_valgrind=0
fi
-if pkg-config --modversion emacs > /dev/null 2>&1; then
- emacs_lispdir=$(pkg-config emacs --variable sitepkglispdir)
-else
- emacs_lispdir='$(prefix)/share/emacs/site-lisp'
+if [ -z "${EMACSLISPDIR}" ]; then
+ if pkg-config --modversion emacs > /dev/null 2>&1; then
+ EMACSLISPDIR=$(pkg-config emacs --variable sitepkglispdir)/notmuch
+ else
+ EMACSLISPDIR='$(prefix)/share/emacs/site-lisp/notmuch'
+ fi
fi
printf "Checking if emacs is available... "
@@ -361,7 +366,7 @@ mandir = ${MANDIR:=\$(prefix)/share/man}
sysconfdir = ${SYSCONFDIR:=\$(prefix)/etc}
# The directory to which emacs lisp files should be installed
-emacs_lispdir=${emacs_lispdir}
+emacslispdir=${EMACSLISPDIR}
# Whether there's an emacs binary available for byte-compiling
HAVE_EMACS = ${have_emacs}
diff --git a/debian/notmuch.install b/debian/notmuch.install
index f412427..e69de29 100644
--- a/debian/notmuch.install
+++ b/debian/notmuch.install
@@ -1 +0,0 @@
-notmuch.el usr/share/emacs/site-lisp/notmuch
diff --git a/emacs/Makefile.local b/emacs/Makefile.local
index 52aca4e..e34da0b 100644
--- a/emacs/Makefile.local
+++ b/emacs/Makefile.local
@@ -20,10 +20,10 @@ install: install-emacs
.PHONY: install-emacs
install-emacs:
- mkdir -p $(DESTDIR)/$(emacs_lispdir)
- install -m0644 $(emacs_sources) $(DESTDIR)$(emacs_lispdir)
+ mkdir -p $(DESTDIR)$(emacslispdir)
+ install -m0644 $(emacs_sources) $(DESTDIR)$(emacslispdir)
ifeq ($(HAVE_EMACS),1)
- install -m0644 $(emacs_bytecode) $(DESTDIR)$(emacs_lispdir)
+ install -m0644 $(emacs_bytecode) $(DESTDIR)$(emacslispdir)
endif
CLEAN := $(CLEAN) $(emacs_bytecode)