summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJameson Graef Rollins <jrollins@finestructure.net>2009-12-23 21:15:55 -0500
committerJameson Graef Rollins <jrollins@finestructure.net>2009-12-23 21:15:55 -0500
commit3650f4d1950e923ea5d28e76a321ce0d62f810de (patch)
treec3cb610e8b37e89fa8c7a23381c9b69102904606
parent518c8c0d3f9d845b2e5a87e83382d61b05fc2958 (diff)
modify install target to depend on install-emacs and install-bash
This makes the Debian package building scripts much simpler.
-rw-r--r--Makefile.local4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.local b/Makefile.local
index 933ff4c..2d54096 100644
--- a/Makefile.local
+++ b/Makefile.local
@@ -27,7 +27,7 @@ notmuch: $(notmuch_client_modules) lib/notmuch.a
notmuch.1.gz: notmuch.1
$(call quiet,gzip) --stdout $^ > $@
-install: all notmuch.1.gz
+install: all notmuch.1.gz install-emacs install-bash
for d in $(DESTDIR)$(prefix)/bin/ $(DESTDIR)$(prefix)/share/man/man1 ; \
do \
install -d $$d ; \
@@ -35,7 +35,7 @@ install: all notmuch.1.gz
install notmuch $(DESTDIR)$(prefix)/bin/
install -m0644 notmuch.1.gz $(DESTDIR)$(prefix)/share/man/man1/
-install-emacs: install emacs
+install-emacs: emacs
for d in $(DESTDIR)/$(emacs_lispdir) ; \
do \
install -d $$d ; \