summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnton Khirnov <wyskas@gmail.com>2009-08-29 15:02:07 +0200
committerAnton Khirnov <wyskas@gmail.com>2009-08-29 15:02:07 +0200
commita77aecbee177152d61df3666015bfb6035606779 (patch)
treead7c646de723154d0a0f958738d74b08903ab14e /setup.py
parent5cd79c5c3e957e26f37d1f3ee4691c0691961792 (diff)
Fix running app from the sources dir.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c2d539d..6fa9ad9 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,9 @@
# Nephilim installer script
from distutils.core import setup
+import shutil
+
+shutil.copyfile('nephilim.py', 'nephilim/nephilim')
setup(name = 'nephilim',
version = '0.1',
@@ -15,5 +18,5 @@ setup(name = 'nephilim',
'Programming Language :: Python :: 2',
'Topic :: Multimedia :: Sound/Audio :: Players'],
packages = ['nephilim', 'nephilim.plugins'],
- scripts = ['scripts/nephilim']
+ scripts = ['nephilim/nephilim']
)