summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnton Khirnov <wyskas@gmail.com>2009-08-28 15:20:08 +0200
committerAnton Khirnov <wyskas@gmail.com>2009-08-28 15:20:08 +0200
commit19fb4edd3c8b75254eeff480b2c6c650745c34a4 (patch)
tree51d80b81ff21bd1d22518b749c28311e1a6aa4bd /setup.py
parent5b946d3f4ae9b44319cd5224a053157a175eafbb (diff)
add installer script
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py19
1 files changed, 19 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..c2d539d
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,19 @@
+# Nephilim installer script
+
+from distutils.core import setup
+
+setup(name = 'nephilim',
+ version = '0.1',
+ description = 'Nephilim MPD client.',
+ author = 'Anton Khirnov',
+ author_email = 'wyskas@gmail.com',
+ classifiers = [
+ 'Development Status :: 3 - Alpha',
+ 'Environment :: X11 Applications :: Qt',
+ 'Intended Audience :: End Users/desktop',
+ 'License :: OSI Approved :: GNU General Public License (GPL)',
+ 'Programming Language :: Python :: 2',
+ 'Topic :: Multimedia :: Sound/Audio :: Players'],
+ packages = ['nephilim', 'nephilim.plugins'],
+ scripts = ['scripts/nephilim']
+)