aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 00000000..4391d61b
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,15 @@
+bin_PROGRAMS = mpd
+SUBDIRS = $(ID3_SUBDIR) $(MAD_SUBDIR)
+mpd_headers = buffer2array.h interface.h command.h playlist.h ls.h \
+ song.h list.h directory.h tables.h utils.h path.h mp3_decode.h \
+ tag.h player.h listen.h conf.h ogg_decode.h volume.h flac_decode.h \
+ audio.h playerData.h stats.h myfprintf.h sig_handlers.h decode.h log.h \
+ audiofile_decode.h charConv.h permission.h mpd_types.h pcm_utils.h
+mpd_SOURCES = main.c buffer2array.c interface.c command.c playlist.c ls.c \
+ song.c list.c directory.c tables.c utils.c path.c mp3_decode.c \
+ tag.c player.c listen.c conf.c ogg_decode.c volume.c flac_decode.c \
+ audio.c playerData.c stats.c myfprintf.c sig_handlers.c decode.c log.c \
+ audiofile_decode.c charConv.c permission.c pcm_utils.c $(mpd_headers)
+
+mpd_CFLAGS = $(MPD_CFLAGS)
+mpd_LDADD = $(MPD_LIBS) $(ID3_LIB) $(MAD_LIB)