aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index e8895748..e246c460 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -12,8 +12,17 @@ protocol_DATA = $(wildcard protocol/*.html)
$(DOCBOOK_HTML): %/index.html: %.xml
$(XMLTO) -o protocol --stringparam chunker.output.encoding=utf-8 html $<
-all-local: $(DOCBOOK_HTML)
+api/html/index.html: doxygen.conf
+ $(DOXYGEN) $<
+
+all-local: $(DOCBOOK_HTML) api/html/index.html
clean-local:
rm -rf $(patsubst %.xml,%,$(DOCBOOK_FILES))
+ rm -rf api
+
+install-data-local: api/html/index.html
+ $(mkinstalldirs) $(docdir)/api/html
+ $(INSTALL_DATA) -c -m 644 api/html/*.html api/html/*.css api/html/*.png api/html/*.gif $(docdir)/api/html
+
endif