aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b5573dc8..88017360 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1372,6 +1372,22 @@ esac
AM_CONDITIONAL(ENABLE_SOLARIS_OUTPUT, test x$enable_solaris_output = xyes)
+dnl --------------------------------- Solaris ---------------------------------
+
+case "$host_os" in
+ mingw32* | windows*)
+ AC_DEFINE(ENABLE_WIN32_OUTPUT, 1, [Define to enable WIN32 wave support])
+ enable_win32_output=yes
+ MPD_LIBS="$MPD_LIBS -lwinmm"
+ ;;
+
+ *)
+ enable_win32_output=no
+ ;;
+esac
+
+AM_CONDITIONAL(ENABLE_WIN32_OUTPUT, test x$enable_win32_output = xyes)
+
dnl --------------------- Post Audio Output Plugins Tests ---------------------
if
test x$enable_alsa = xno &&
@@ -1388,6 +1404,7 @@ if
test x$enable_recorder_output = xno &&
test x$enable_shout = xno &&
test x$enable_solaris_output = xno &&
+ test x$enable_win32_output = xno &&
AC_MSG_ERROR([No Audio Output types configured!])
fi
@@ -1523,6 +1540,7 @@ results(mvp, [Media MVP])
results(shout, [SHOUTcast])
echo -ne '\n\t'
results(solaris, [Solaris])
+results(win32_output, [WIN32 wave])
if
test x$enable_shout = xyes ||