aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8a559adc..77885a36 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -576,12 +576,20 @@ sparse-check:
if ENABLE_TEST
noinst_PROGRAMS = \
+ test/read_conf \
test/run_decoder \
test/read_tags \
test/run_encoder \
test/run_output \
test/software_volume
+test_read_conf_CPPFLAGS = $(AM_CPPFLAGS) \
+ $(GLIB_CFLAGS)
+test_read_conf_LDADD = $(MPD_LIBS) \
+ $(GLIB_LIBS)
+test_read_conf_SOURCES = test/read_conf.c \
+ src/conf.c src/buffer2array.c src/utils.c
+
test_run_decoder_CPPFLAGS = $(AM_CPPFLAGS) \
$(ID3TAG_CFLAGS) \
$(INPUT_CFLAGS) $(DECODER_CFLAGS)