aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4f472ba3..351ad5d6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -577,6 +577,7 @@ if ENABLE_TEST
noinst_PROGRAMS = \
test/read_conf \
+ test/run_input \
test/run_decoder \
test/read_tags \
test/run_encoder \
@@ -590,6 +591,17 @@ test_read_conf_LDADD = $(MPD_LIBS) \
test_read_conf_SOURCES = test/read_conf.c \
src/conf.c src/buffer2array.c src/utils.c
+test_run_input_CPPFLAGS = $(AM_CPPFLAGS) \
+ $(INPUT_CFLAGS)
+test_run_input_LDADD = $(MPD_LIBS) \
+ $(INPUT_LIBS) \
+ $(GLIB_LIBS)
+test_run_input_SOURCES = test/run_input.c \
+ src/conf.c src/buffer2array.c src/utils.c \
+ src/tag.c src/tag_pool.c src/tag_save.c \
+ $(ARCHIVE_SRC) \
+ $(INPUT_SRC)
+
test_run_decoder_CPPFLAGS = $(AM_CPPFLAGS) \
$(ID3TAG_CFLAGS) \
$(INPUT_CFLAGS) $(DECODER_CFLAGS)