aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8cdc72c7..ff575456 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -542,6 +542,7 @@ libdecoder_plugins_a_CPPFLAGS = $(AM_CPPFLAGS) \
$(OPUS_CFLAGS) \
$(FFMPEG_CFLAGS) \
$(MPCDEC_CFLAGS) \
+ $(ADPLUG_CFLAGS) \
$(FAAD_CFLAGS)
DECODER_LIBS = \
@@ -561,6 +562,7 @@ DECODER_LIBS = \
$(MP4FF_LIBS) \
$(FFMPEG_LIBS) \
$(MPCDEC_LIBS) \
+ $(ADPLUG_LIBS) \
$(FAAD_LIBS)
DECODER_SRC =
@@ -594,6 +596,12 @@ if HAVE_WAVPACK
libdecoder_plugins_a_SOURCES += src/decoder/wavpack_decoder_plugin.c
endif
+if HAVE_ADPLUG
+libdecoder_plugins_a_SOURCES += \
+ src/decoder/AdPlugDecoderPlugin.cxx \
+ src/decoder/AdPlugDecoderPlugin.h
+endif
+
if HAVE_FAAD
libdecoder_plugins_a_SOURCES += src/decoder/faad_decoder_plugin.c
endif