aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-09-24 07:20:26 +0200
committerMax Kellermann <max@duempel.org>2008-09-24 07:20:26 +0200
commitd32f49a90ba69525884ee6fe4f2055792aa10430 (patch)
tree2efa2310c8ccc8d49f5f3b856c8d15162dd5b251 /src/Makefile.am
parent8f4ebf0caf8514fb7838eb27b848e5a4cccaae12 (diff)
output: one thread per audio output
To keep I/O nastiness and latencies away from the core, move the audio output code to a separate thread, one per output. The thread is created on demand, and currently runs until mpd exits.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 368e051f..2069c45c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -37,6 +37,7 @@ mpd_headers = \
audioOutput.h \
output_api.h \
output_list.h \
+ output_thread.h \
output_control.h \
audioOutputs/audioOutput_shout.h \
buffer2array.h \
@@ -114,6 +115,7 @@ mpd_SOURCES = \
audio.c \
audioOutput.c \
output_list.c \
+ output_thread.c \
output_control.c \
output_init.c \
buffer2array.c \