aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-01-29 21:42:10 +0100
committerMax Kellermann <max@duempel.org>2009-01-29 21:42:10 +0100
commitcaa4d28f044d70012cd113f324e6500c0b57d491 (patch)
tree5f904a7668b602480c660d04e4cbc3b075b4be99 /src/Makefile.am
parent36ca114629d8e9bef2faff3716ccdf8f7641fd10 (diff)
added support for the MMS protocol
This patch implements the MMS protocol, by using libmms. It is quite experimental: it does not support seeking yet, and it is currently using synchronous I/O, which causes MPD to hang while waiting for the server.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7cbd3154..de9c99f1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -4,6 +4,7 @@ mpd_CFLAGS = $(MPD_CFLAGS)
mpd_CPPFLAGS = \
$(SQLITE_CFLAGS) \
$(CURL_CFLAGS) \
+ $(MMS_CFLAGS) \
$(AO_CFLAGS) $(ALSA_CFLAGS) \
$(SHOUT_CFLAGS) \
$(OGGVORBIS_CFLAGS) $(VORBISENC_CFLAGS) \
@@ -17,6 +18,7 @@ mpd_CPPFLAGS = \
mpd_LDADD = $(MPD_LIBS) \
$(SQLITE_LIBS) \
$(CURL_LIBS) \
+ $(MMS_LIBS) \
$(AO_LIBS) $(ALSA_LIBS) \
$(SHOUT_LIBS) \
$(OGGVORBIS_LIBS) $(VORBISENC_LIBS) $(FLAC_LIBS) \
@@ -64,6 +66,7 @@ mpd_headers = \
input_stream.h \
input_file.h \
input_curl.h \
+ input_mms.h \
icy_metadata.h \
client.h \
listen.h \
@@ -314,6 +317,10 @@ if HAVE_CURL
mpd_SOURCES += input_curl.c icy_metadata.c
endif
+if ENABLE_MMS
+mpd_SOURCES += input_mms.c
+endif
+
if HAVE_ALSA
mpd_SOURCES += output/alsa_plugin.c