aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-02-11 18:00:41 +0100
committerMax Kellermann <max@duempel.org>2009-02-11 18:00:41 +0100
commit5090cf6484f5e7464aeba54d19500cc334a80fad (patch)
tree1e6cc079a0b23128a529aea3f6042581027828c9 /src/Makefile.am
parent5484aaee5f9407e61d77e81236b4942c12b94556 (diff)
audio: replaced parseAudioConfig() with audio_format_parse()
Added audio_format_parse() in a separate library, with a modern interface: return a GError instead of logging errors. This allows the caller to deal with the error.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 98fe8bea..2e7b769d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -35,6 +35,7 @@ mpd_headers = \
ack.h \
audio.h \
audio_format.h \
+ audio_parser.h \
audioOutput.h \
output_internal.h \
output_api.h \
@@ -136,6 +137,7 @@ mpd_SOURCES = \
$(mpd_headers) \
notify.c \
audio.c \
+ audio_parser.c \
audioOutput.c \
output_api.c \
output_list.c \