aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-02-22 17:18:28 +0100
committerMax Kellermann <max@duempel.org>2009-02-22 17:18:28 +0100
commitf6e5c00726cf3322813242b804f3bf2369cfa337 (patch)
tree5beb10943c8a4c40666746edf68e79f7fd65fc08 /configure.ac
parentf7c685f1abaf8201d8bdc2b520b5529dfaf474dd (diff)
shout: use the new encoder API
Removed shout's encoder plugin API in favor of the new generic encoder plugin API.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 1 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 572917cd..8c1e1d2c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -557,8 +557,7 @@ if test x$enable_shout_ogg = xyes; then
enable_shout_ogg=no
fi
if test x$enable_shout_ogg = xyes; then
- PKG_CHECK_MODULES(VORBISENC, [vorbisenc],
- AC_DEFINE(HAVE_SHOUT_OGG, 1, [Define to enable ogg streaming support]),
+ PKG_CHECK_MODULES(VORBISENC, [vorbisenc],,
enable_shout_ogg=no)
fi
fi
@@ -573,9 +572,6 @@ if test x$enable_shout_mp3 = xyes; then
AC_MSG_WARN([disabling mp3 shout streaming support because lame is not enabled])
enable_shout_mp3=no
fi
- if test x$enable_shout_mp3 = xyes; then
- AC_DEFINE(HAVE_SHOUT_MP3, 1, [Define to enable mp3 streaming support])
- fi
fi
if test x$enable_shout_ogg = xyes || test x$enable_shout_mp3 = xyes; then
@@ -586,8 +582,6 @@ else
fi
AM_CONDITIONAL(HAVE_SHOUT, test x$enable_shout = xyes)
-AM_CONDITIONAL(HAVE_SHOUT_OGG, test x$enable_shout_ogg = xyes)
-AM_CONDITIONAL(HAVE_SHOUT_MP3, test x$enable_shout_mp3 = xyes)
AM_CONDITIONAL(ENABLE_ENCODER, test x$enable_shout = xyes)
AM_CONDITIONAL(ENABLE_VORBIS_ENCODER, test x$enable_shout_ogg = xyes)