aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-04-13 20:39:51 +0200
committerMax Kellermann <max@duempel.org>2009-04-13 20:39:51 +0200
commitc824013e94743feb05c45fa82c3e81cceda120fa (patch)
treee7f42ec7b2681f0a337d8a6dd93aeb082773f9ee /configure.ac
parent2cbda895fb43fb2d7ddcec6a0c78f1dc3d3a19b4 (diff)
configure.ac: fail when bzip2 plugin is enabled but not found
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5848942b..67945b51 100644
--- a/configure.ac
+++ b/configure.ac
@@ -310,7 +310,7 @@ AC_ARG_ENABLE(bzip2,
if test x$enable_bzip2 = xyes; then
AC_CHECK_LIB(bz2, BZ2_bzDecompressInit,
[MPD_LIBS="$MPD_LIBS -lbz2"],
- enable_bzip2=no)
+ [AC_MSG_ERROR([libbz2 not found])])
fi
AM_CONDITIONAL(HAVE_BZ2, test x$enable_bzip2 = xyes)