aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWarren Dukes <warren.dukes@gmail.com>2005-03-17 00:56:31 +0000
committerWarren Dukes <warren.dukes@gmail.com>2005-03-17 00:56:31 +0000
commitc1057f0c347f80579461d6a06f645e2bb1c7b673 (patch)
treeb3d05ad43b9e521a9712f8928661a5ca40a91596 /configure.ac
parent70865740fb3f5557ae943ef3571cfc96573f032e (diff)
slight tweak of avuton's idea of causing an error when no audio output's found
git-svn-id: https://svn.musicpd.org/mpd/trunk@3093 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 8 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index e28457ae..3395fdb4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -126,14 +126,6 @@ if test x$enable_oss = xyes; then
AC_CHECK_HEADER(sys/soundcard.h,[enable_oss=yes;AC_DEFINE(HAVE_OSS,1,[Define to enable OSS])],[AC_MSG_WARN(Soundcard headers not found -- disabling OSS support);enable_oss=no])
fi
-if test x$enable_ao = xno &&
- test x$enable_oss = xno &&
- test x$enable_shout = xno &&
- test x$enable_alsa = xno &&
- test x$enable_osx = xno; then
- AC_MSG_ERROR("Cannot compile without an output target")
-fi
-
if test x$enable_alsa = xyes; then
AM_PATH_ALSA(0.9.0,[AC_DEFINE(HAVE_ALSA,1,[Define to enable ALSA support]) MPD_LIBS="$MPD_LIBS $ALSA_LIBS" MPD_CFLAGS="$MPD_CFLAGS $ALSA_CFLAGS"],enable_alsa=no)
fi
@@ -559,22 +551,6 @@ fi
echo ""
-echo "Volume Mixer Support:"
-
-if test x$enable_oss = xyes; then
- echo "OSS mixer support .............enabled"
-else
- echo "OSS mixer support .............disabled"
-fi
-
-if test x$enable_alsa = xyes; then
- echo "ALSA mixer support ............enabled"
-else
- echo "ALSA mixer support ............disabled"
-fi
-
-echo ""
-
echo "Audio Output Support:"
if test x$enable_ao = xyes; then
echo "Playing audio via libao .......enabled"
@@ -608,6 +584,14 @@ fi
echo ""
+if test x$enable_ao = xno &&
+ test x$enable_oss = xno &&
+ test x$enable_shout = xno &&
+ test x$enable_alsa = xno &&
+ test x$enable_osx = xno; then
+ AC_MSG_ERROR("No Audio Output types configured!")
+fi
+
echo "Audio Format Support:"
if test x$enable_id3 = xyes; then