aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJ. Alexander Treuman <jat@spatialrift.net>2007-06-13 14:15:30 +0000
committerJ. Alexander Treuman <jat@spatialrift.net>2007-06-13 14:15:30 +0000
commitb496239e762cc354d9f5a9272893d35615e60144 (patch)
tree0396e0f062dac031020ced535ce51dee32379d0f /configure.ac
parent1928a40486ccead50977daac78f936a75a9c475f (diff)
Adding FIFO audio output. This is pretty much identical to the old one,
except that it now uses a timer for throttling. git-svn-id: https://svn.musicpd.org/mpd/trunk@6621 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2e00d4bb..204943c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,6 +69,7 @@ AC_ARG_ENABLE(oss,[ --disable-oss disable OSS support (default: enabl
AC_ARG_ENABLE(alsa,[ --disable-alsa disable ALSA support (default: enable)],[enable_alsa=$enableval],[enable_alsa=yes])
AC_ARG_ENABLE(jack,[ --disable-jack disable jack support (default: enable)],[enable_jack=$enableval],[enable_jack=yes])
AC_ARG_ENABLE(pulse,[ --disable-pulse disable support for the PulseAudio sound server (default: enable)],[enable_pulse=$enableval],[enable_pulse=yes])
+AC_ARG_ENABLE(fifo,[ --disable-fifo disable support for writing audio to a FIFO (default: enable)],[enable_fifo=$enableval],[enable_fifo=yes])
AC_ARG_ENABLE(mvp,[ --enable-mvp enable support for Hauppauge Media MVP (default: disable)],[enable_mvp=$enableval],[enable_mvp=no])
AC_ARG_ENABLE(oggvorbis,[ --disable-oggvorbis disable Ogg Vorbis support (default: enable)],[enable_oggvorbis=$enableval],enable_oggvorbis=yes)
AC_ARG_ENABLE(oggflac,[ --disable-oggflac disable OggFLAC support (default: enable)],[enable_oggflac=$enableval],enable_oggflac=yes)
@@ -197,6 +198,12 @@ if test x$enable_lsr = xyes; then
[enable_lsr=no;AC_MSG_WARN([libsamplerate not found -- disabling])])
fi
+if test x$enable_fifo = xyes; then
+ AC_CHECK_FUNC([mkfifo],
+ [enable_fifo=yes;AC_DEFINE([HAVE_FIFO], 1, [Define to enable support for writing audio to a FIFO])],
+ [enable_fifo=no;AC_MSG_WARN([mkfifo not found -- disabling support for writing audio to a FIFO])])
+fi
+
if test x$enable_mvp = xyes; then
AC_DEFINE(HAVE_MVP,1,[Define to enable Hauppauge Media MVP support])
fi
@@ -664,6 +671,12 @@ else
echo " PulseAudio support ............disabled"
fi
+if test x$enable_fifo = xyes; then
+ echo " FIFO support ..................enabled"
+else
+ echo " FIFO support ..................disabled"
+fi
+
if test x$enable_mvp = xyes; then
echo " Media MVP support .............enabled"
else
@@ -685,6 +698,7 @@ if test x$enable_ao = xno &&
test x$enable_osx = xno &&
test x$enable_pulse = xno &&
test x$enable_jack = xno &&
+ test x$enable_fifo = xno &&
test x$enable_mvp = xno; then
AC_MSG_ERROR([No Audio Output types configured!])
fi