aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2011-10-08 14:50:44 +0200
committerMax Kellermann <max@duempel.org>2011-10-08 14:50:44 +0200
commitb43bf4dd741f81239c7ae0c99a048ef0be6286ed (patch)
tree3cb219018da3e22bab9b69c1bb6f94bb312b0329 /configure.ac
parent14424281a0e1407ca04ef05a50541a4178f70e91 (diff)
parent5ed0eb51d16507dcca9764771af8f05f08a078f9 (diff)
Merge branch 'v0.16.x'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 98062eea..84f36f8f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,7 +36,15 @@ AC_PROG_MAKE_SET
PKG_PROG_PKG_CONFIG
AC_ARG_WITH([systemdsystemunitdir],
AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files]),
- [], [with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)])
+ [], [with_systemdsystemunitdir=no])
+if test "x$with_systemdsystemunitdir" = xyes; then
+ AC_MSG_CHECKING(for systemd)
+ with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)
+ if test -z "$with_systemdsystemunitdir"; then
+ AC_MSG_ERROR([Failed to detect systemd])
+ fi
+ AC_MSG_RESULT([$with_systemdsystemunitdir])
+fi
if test "x$with_systemdsystemunitdir" != xno; then
AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
fi