aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2011-12-13 21:57:44 +0100
committerMax Kellermann <max@duempel.org>2011-12-13 21:57:44 +0100
commitaa4f45b9a56779355f15f867dce9ab0759cb5f7a (patch)
treee0793dfab38b5540a02c8a8e3d4f2612fe2c3faa /configure.ac
parent006b8fa3f07e948cbd277e91546dd815769d7a5e (diff)
parent96ad5b84446be0bf603895adaf0ec2e97bee11aa (diff)
Merge branch 'v0.16.x'
Conflicts: NEWS configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7c3fb3fc..bcf54033 100644
--- a/configure.ac
+++ b/configure.ac
@@ -440,6 +440,11 @@ dnl ---------------------------------------------------------------------------
PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.12 gthread-2.0],,
[AC_MSG_ERROR([GLib 2.12 is required])])
+if test x$GCC = xyes; then
+ # suppress warnings in the GLib headers
+ GLIB_CFLAGS=`echo $GLIB_CFLAGS |sed -e 's,-I/,-isystem /,g'`
+fi
+
dnl ---------------------------------------------------------------------------
dnl Protocol Options
dnl ---------------------------------------------------------------------------
@@ -454,7 +459,11 @@ if test x$enable_ipv6 = xyes; then
AC_EGREP_CPP([AP_maGiC_VALUE],
[
#include <sys/types.h>
+#ifdef WIN32
+#include <winsock2.h>
+#else
#include <sys/socket.h>
+#endif
#include <netdb.h>
#ifdef PF_INET6
#ifdef AF_INET6