aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDenis Krjuchkov <denis@crazydev.net>2013-01-11 13:51:39 +0600
committerDenis Krjuchkov <denis@crazydev.net>2013-01-11 13:51:39 +0600
commita98aa666203cad87913303d2f8b9ca07640518c3 (patch)
tree7fc9aa4231dbe86e227cd50d84f16d937898c28b /configure.ac
parent631a26899610e11a6c6456c2a5750dace68958f7 (diff)
string_util.c: provide fallback strndup() implementation
This patch also adds extern "C" { } wrapper around string_util.h to allow its usage in C++ code
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1cd27ffe..5515eb18 100644
--- a/configure.ac
+++ b/configure.ac
@@ -135,6 +135,8 @@ AC_SEARCH_LIBS([gethostbyname], [nsl])
AC_CHECK_FUNCS(pipe2 accept4 eventfd)
+AC_CHECK_FUNCS(strndup)
+
AC_SEARCH_LIBS([exp], [m],,
[AC_MSG_ERROR([exp() not found])])