aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2007-01-14 04:25:21 +0000
committerEric Wong <normalperson@yhbt.net>2007-01-14 04:25:21 +0000
commit8d11eaff55cd9bf373f9cf171ccb371bb604dd5a (patch)
tree695f7ba7ab5ec8ae88dc6e75f8a6cb8723e747a7 /configure.ac
parent6f341e9a3b047f8eea0e7ff3b52488bbaa6e23ff (diff)
configure.ac: no longer drop MPD_CFLAGS if shout is enabled
I'm an idiot for not noticing that :x git-svn-id: https://svn.musicpd.org/mpd/trunk@5256 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index fcdcc794..8b41bbad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,11 +20,9 @@ AC_DEFINE(PROTOCOL_VERSION, "0.12.1", [The mpd protocol version])
MPD_LIBS=""
MPD_CFLAGS=""
-case "$CC" in
-*gcc*)
+if test x$GCC = xyes; then
MPD_CFLAGS="-Wall -Wmissing-prototypes"
- ;;
-esac
+fi
if test -z "$prefix" || test "x$prefix" = xNONE; then
local_lib=
@@ -515,7 +513,7 @@ elif test x$enable_oggvorbis = xyes; then
if test x$enable_shout = xyes; then
MPD_LIBS="$MPD_LIBS $VORBISENC_LIBS"
- MPD_CFLAGS="$VORBISFILE_CFLAGS $VORBISENC_CFLAGS"
+ MPD_CFLAGS="$MPD_CFLAGS $VORBISFILE_CFLAGS $VORBISENC_CFLAGS"
fi
fi
fi